Linux – ERROR: lib load error – NativeIO

If you get the above error when running FlexRAID on Linux, you might need to install one or more the following dependencies:

- libc6-i386
- lib32gcc1
- lib32stdc++6

or

- libstdc++.i686

So:

  1. Ensure that you are running GLIBC version 2.11 or higher.
    You can verify your GLIBC version by executing “ldd –version”.
  2. Run ldd on the executable to get the full list of dependencies for your distro.
    Ex: ldd FlexRAID
  3. Install the missing dependencies if any

Notice:
If you get notice of deprecation in the latest distros, try: sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0 lib32stdc++6

Be Sociable, Share!

Revisions

No comments yet.

Leave a Reply

13 − three =